small-map

FAQs

What is Infospeed? What is Class?

What does the annual subscription cover?

Can we import our current data into Class?

How long from the moment we order Class until we are up and running?

Can we add or remove modules or the number of users whenever we want?

What are concurrent users?

How many users will I need?

Why do I need a different number of Teacher Portal users?

What are the benefits of Class Cloud?

Is Class Cloud and Class Web the same thing?

Is Class Cloud compatible with Apple Mac?

I’m an existing customer. How do I move from my current setup to Class Cloud?

Can Class link to other external systems we use?

Important Class .NET Changes

Microsoft SQL Supported Versions
The latest version of Class is now compatible with Microsoft SQL Server 2008 to 2016.
Microsoft SQL Server 2005 (and 2005 Express) are no longer supported.

Please ensure that you review the latest Release Notes before upgrading.


Upgrading to Class 8.2.0?
An update to the Class Console will be required. Please install the update using ConsoleSetup.msi found within the Upgrade Zip file.

If you do not use this updated Console, you will encounter an error when checking for updates.


Important Notice – Latest release of Class 8.2.0 (NEW!)

When upgrading to Class 8.2.0, a new SMS Account ID will be required.  Please see Release Notes & HS239 for further information.

There has been a major enhancement to the Group Master Document templates. Some of the merge fields have been updated and after the upgrade may result in some important information missing. Therefore, changes will need to be made to the templates.

Detailed information is in the Release Notice which can be downloaded from our website or obtained by emailing support@infospeed.co.uk. We strongly recommend that this is read before the upgrade is carried out.

The Infospeed Team.